undefinierter Index

Message

Hallo,

wir haben gestern dieses Plugin erworben und gleich installiert.
Beim kontrollieren eventuell aufgetretener Fehler bin ich (Uwe Admin von tt-modellbahnforum.de) auf die folgende Fehlermeldung gestoßen. Ob diese nun wirklich mit dem Plugin zusammenhängt, kann ich leider nicht abschließend beurteilen. Aber die Meldungen die kommen haben etwas mit "UserIPLogListener" zu tun, was mich annehmen lässt, dass hier irgendwo im Zusammenspiel mit bisher installierter Software ein Fehler auftreten könnte?
Hier mal die ganze Fehlermeldung:


Vielleicht könnten Sie mir einen Tip geben was genau diese Meldung zu bedeuten hat, vielen Dank.

MfG Uwe

Comments 6

  • Das sieht so aus als ob es tatsächlich vom Benutzer IP-Log kommt. Komischerweise wird da eine Server-Variable abgefragt, die bei dem Server nicht definiert wurde.


    Um genau zu sein diese:


    HTTP_ACCEPT_LANGUAGE


    Warum die nicht bei dir ausgelesen werden kann ist mir unklar.


    Ich werde es mir mal anschauen... Welcher Server läuft denn und welcher Browser wurde genutzt?

  • Ohne weitere Informationen kann ich den Fehler nicht eingrenzen... als erstes muss ich wissen


    Welcher Browser


    Genutzt wurde...

  • Inzwischen habe ich festgestellt, dass nicht jeden Tag dieser Fehler auftritt, auch nicht immer zur gleichen Zeit. Zwei weitere Fehler dieser Art waren am 2.4. zu unterschiedlichen Zeiten vorhanden.
    Was ich aber beim durchschauen der Browserkennungen, mit meinen bescheidenen Kenntnissen was die Browserdefinition angeht, sehe ich diese Browserkennung, vom 2.4.:

    Code
    1. Mozilla/5.0 (Linux; Android 8.1.0; SAMSUNG SM-J730F Build/M1AJQ) AppleWebKit/537.36 (KHTML, like Gecko) SamsungBrowser/8.2 Chrome/63.0.3239.111 Mobile Safari/537.36

    Also wenn ich das im Netz suche, scheint es auf Samsung Browser 7.4 hinaus zu laufen?

    und der oben im ersten Post genannte scheint ein Samsung Browser 8.2 zu sein

    Code
    1. Mozilla/5.0 (Linux; Android 5.1.1; SAMSUNG SM-G800F/G800FXXU1BOL4 Build/LMY47X) AppleWebKit/537.36 (KHTML, like Gecko) SamsungBrowser/8.2 Chrome/63.0.3239.111 Mobile Safari/537.36

    zumindest nach dieser Webseite

    Oder was meinst Du mit der Frage des Browsers?

    Vielleicht hilft ja folgendes Bild

    Browserkennung.jpg


    In dieser Ansicht tauchen oben genannte Browser nicht auf (vielleicht daher die Fehlermeldung?)

    Du meinst Http-Language wird nicht abgefragt, aber ist nicht in der Tabelle die Anzeige "Sprache" genau diese Angabe? Die Safari-Mobile-Browser scheinen auch keine HTTP-LANGUAGE mit zu liefern, werden aber zumindest mit gelistet.


    Ich hoffe ich konnte weiter helfen?


    Gruß Uwe

  • Also das liegt definitiv am Samsung - Browser... die Sprache in der Tabelle hat so nicht viel mit der Sprache zu tun, die vom Browser gelistet wurde. Das ist mit der Sprache etwas komplizierter. Wichtig ist hier, dass ich herausgefunden habe, dass der Andriod-Browser nicht die nötige Server-Variable "HTTP-LANGUAGE" setzt bzw. mitliefert.


    Eventuell muss ich mir dann überlegen, wie ich wenn es nicht vom Samsung gesendet wird, wie ich die Variable sonst mit einer Sprache versehen kann.


    Aber der Fehler liegt definitiv an dem verwendeten Browser. Der Liefert nicht die sonst übliche und im Standard immer vorhandene Variable nicht mit. Für mich ist das ehr ein Fehler vom Samsung und nicht von dem Plugin.


    Aber ich überlege mir mal was, wie ich den Fehler dann umgehen kann.

  • Na das klingt doch erstmal, nach gefundener Ursache, gestern war es übrigens wieder so ein Samsung-Browser, in Version 9.2. Keine Ahnung wer so etwas benutzt, auf jeden Fall nur (nicht=Schreibfehler) sehr wenige, zumindest bei uns.:D

    This comment has been already edited 1 times, the last time by „Modellbahnforum“ ()